Cannot render plots under Windows


I installed the nuscense-dev toolkit on Windows 10. I use Anaconda as my environment. I am able to load the data and examine it. However, when I tun a command like:
The command runs without error or warnings but it does not produce any output.

Using the Jupiter Notebook in a web browser it works fine. Can someone help me with this?

I checked if tkinter is installed properly and it is. The version is 8.6.8 and when I run tkinter._test() the test window pops up.

Hi. Unfortunately we do not support Windows and this issue does not seem to be related to our code, but to the setup of matplotlib on your machine. I suggest you google more on tkinter, e.g. . Setting up tkinter can be annoying, even on some Ubuntu machines.

1 Like

Thanks. That is helpful to know. I have access to Ubuntu machine so I can try on that one.

Hi Nikola,

I’m having no issues with the nuScenes devkit on Windows 10.
The plots are displayed after executing

1 Like

I seriously love you. That worked. I spent hours reading about tkinter. Praise the Lord!!!

1 Like